viernes, 8 de abril de 2011

Debian Squeeze: Instalar Nueva Versión Skype 2.2 desde consola

Skype se actualiza a la versión 2.2 beta para Linux (Por fin), pues bien mostrare el procedimiento para instalarlo en Debian Squeeze.
Primero nos dirigimos a la pagina oficial de Skype desde aquí, seleccionamos en el menú desplegable que nos muestra donde dice Debian 5+ 64bits (en mi caso de 64bits), seguido de esto esperamos a que se descargue el archivo .deb, al finalizar proseguimos a instalarlo de la siguiente forma:
dpkg -i nombre_del_arhivo.deb
Si todo va bien se instalara sin ningún problema, pero en lo personal a mi me marcaba unas dependencias faltantes, en este punto deben de leer bien el error que les mande la terminal en mi caso me mandaba esto: 

(Leyendo la base de datos ... 126255 ficheros o directorios instalados actualmente.)
Preparando para reemplazar skype 2.2.0.25-1 (usando skype-debian_2.2.0.25-1_amd64.deb) ...
Desempaquetando el reemplazo de skype ...
dpkg: problemas de dependencias impiden la configuración de skype:
 skype depende de lib32stdc++6 (>= 4.1.1-21); sin embargo:
  El paquete `lib32stdc++6' no está instalado.
 skype depende de lib32asound2 (>> 1.0.14); sin embargo:
  El paquete `lib32asound2' no está instalado.
 skype depende de ia32-libs (>= 1.6); sin embargo:
  El paquete `ia32-libs' no está instalado.
 skype depende de lib32gcc1 (>= 1:4.1.1-21+ia32.libs.1.19); sin embargo:
  El paquete `lib32gcc1' no está instalado.
 skype depende de ia32-libs-gtk (>= 2.7); sin embargo:
  El paquete `ia32-libs-gtk' no está instalado.
dpkg: error al procesar skype (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Se encontraron errores al procesar:
 skype

Claramente como se ve en el mensaje me decía que me hacían falta dependencias, las cuales me daban el nombre para instalarlas seguido de esto, copie y pegue el nombre de cada dependencia y con ayuda de apt-get install proseguí a instalarlos de la siguiente forma:
# apt-get install lib32stdc++6 lib32asound2 ia32-libs lib32gcc1 ia32-libs-gtk
Y de nuevo me marcaba error siguiente:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
 ia32-libs : Depende: lib32bz2-1.0 pero no va a instalarse
             Depende: lib32ncurses5 (>= 5.7+20100313) pero no va a instalarse
             Depende: lib32v4l-0 (>= 0.5.0) pero no va a instalarse
             Depende: lib32z1 (>= 1:1.2.3.3.dfsg) pero no va a instalarse
 ia32-libs-gtk : Depende: lib32z1 (>= 1:1.1.4) pero no va a instalarse
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).

Nuevamente leamos bien el error que nos arroja, algo en lo particular que me gusta de linux es que no todo es sencillo de instalar esto obliga a leer mucho para poder seguir adelante, pero así como te exige leer un poco mas, también te ayuda mucho con sus mensajes de error generados, de hecho en este caso hasta nos dice que probemos apt-get -f install lo cual hice como muestro a continuación:
# apt-get -f install
Después de esto se agarro a instalar las dependencias de arriba todas juntas sin problema alguno, después de esto mi intuición me decía que ya podría instalar ahora si el paquete .deb, así que volví a intentarlo de la siguiente manera:
dpkg -i nombre_del_arhivo.deb
Ahora si sin problema alguno se me instalo, ahora para abrir esta nueva versión de skype en Debian Squeeze nos dirigimos a Aplicaciones>Internet>Skype y listo.
Espero les sirva mi pequeña guía de como instalarlo, cualquier duda en la sección de comentarios.

No hay comentarios:

Publicar un comentario